Installation

Dependencies

PennyLane requires the following libraries be installed:

as well as the following Python packages:

If you currently do not have Python 3 installed, we recommend Anaconda for Python 3, a distributed version of Python packaged for scientific computation.

Installation

Installation of PennyLane, as well as all required Python packages mentioned above, can be installed via pip:

$ python -m pip install pennylane

Make sure you are using the Python 3 version of pip.

Alternatively, you can install PennyLane from the source code by navigating to the top-level directory and running

$ python setup.py install

Software tests

The PennyLane test suite requires the Python pytest package; this can be installed via pip:

$ python -m pip install pytest

To ensure that PennyLane is working correctly, the test suite can then be run by navigating to the source code folder and running

$ make test

Documentation

To build the documentation, the following additional packages are required:

These can both be installed via pip:

$ python3 -m pip install sphinx sphinxcontrib-bibtex

To build the HTML documentation, go to the top-level directory and run

$ make docs

The documentation can then be found in the doc/_build/html/ directory.